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1 Introduction

This user guide describes how to configure and use Bria. Bria is a softphone from CounterPath that enables you 
to make VoIP voice and video calls, send and receive instant messages, share online status (presence) 
information, and exchange files. 

This user guide is intended for:

• System administrators who have purchased Bria from the CounterPath website and are deploying Bria for 
use by the staff in an enterprise. The administrator should be familiar with PBX solutions, telephony and 
VoIP telephony.

• Service providers who have purchased Bria from CounterPath Sales, without further customization or 
engineering changes.

• End users who have purchased Bria from the CounterPath website.
• End users in an enterprise or subscribers of a service provider who has deployed Bria.

This user guide is divided into two parts: the first part describes how to use Bria; the second part describes how 
to configure Bria. 

• If you are working in an enterprise and you have a system administrator, read the first part “Using Bria”. It 
is assumed that your system administrator has configured Bria on your behalf. 

• If you are deploying Bria without the help of a system administrator, read the Configuration part first, then 
read the rest of the user guide.

• If you are a system administrator at an enterprise or a service provider, read the Configuration part. You can 
deploy Bria either by manually configuring via the softphone GUI or by using a provisioning server. If you 
decide to implement remote provisioning, you also need to read “Bria 4 Provisioning Guide”.

Standard Telephone Features
The CounterPath Bria 4 for Windows softphone has all standard enterprise telephone features, including:

• Call display and Message Waiting Indicator (MWI).
• Speakerphone and Mute.
• Redial, Hold, Do Not Disturb.
• Call history – list of received, missed, and dialed calls.
• Call forward.
• Call transfer.
• Call record.
• Auto answer.
• Five-party audio conferencing. (hosted locally)
• Three-party video conferencing. (hosted locally)
1
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Enhanced Features and Functions
Bria also supports the following features and functions:

• Video
• Support for several languages in addition to English: Chinese, Dutch, French, German, Italian, Japanese, 

Portuguese, Russian, and Spanish. 
• IM and presence using the SIP SIMPLE protocol and the XMPP protocol.
• IM conferencing (group chat) via an XMPP account.
• Corporate chat rooms.
• Contact list containing the individual user’s contacts.
• Directory containing names from a shared LDAP directory or Microsoft® Active Directory®.
• Access to Microsoft Outlook® contacts from within Bria.
• File transfer via an XMPP account.
• Support for DTMF (RFC 2833, SIP INFO or inband DTMF). 
• Automatic detection of audio and video devices.
• Acoustic echo cancellation, automatic gain control, voice activity detection.
• Support for the following audio codecs (not all these codecs are included in the retail brands):

 G.711aLaw, G.711uLaw, G.722, G.729, OPUS, SILK narrowband, SILK wideband, SILK super-wideband, 
Speex, Speex Wideband.

• Support for the following video codecs:
H.263, H.263+ 1998, H.264, VP8.

• Support for these firewall traversal solutions: STUN, TURN, or ICE.
2



Using Bria

2 Getting Started

2.1 Starting Bria
Bria can be deployed with or without a configuration server. If you are deploying Bria with the help of a system 
administrator, follow the instructions given by your system administrator. 

1. Install Bria: obtain the Bria setup executable file and follow the prompts in the install wizard.

2. Start Bria as you would any other program: Use the Windows Start menu or double-click the desktop icon. 
The Bria Login dialog appears. 

3. Set the profile to the value specified by your system administrator. Typically:

• I will manually input my account configuration: Choose this if you have no login or configuration 
server. This profile does not use the Login feature. Login is used only in enterprise deployments in 
which a system administrator has set up a provisioning server to automatically configure Bria for you. 
You must configure a SIP account as described in “Creating Accounts” on page 67. 

• Enter your Configuration Server’s details: Choose this if you have a login server address and login 
credentials from your system administrator. Bria will be automatically configured for you.

Subsequent Startups
After the first-time startup, the Bria Login dialog will not appear if you selected the “No login” profile. 

(If you started up the first time with “I will manually input my account configuration” but in fact you do need to 
log in, go to the menu and choose Softphone > Preferences > Application and enable login. See page 85.)
3
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Making a First Call
Try making calls with your new phone (page 10). 

Having Troubles?
Bria includes these tools for helping you troubleshoot problems. From the menu, choose Help > 
Troubleshooting (page 63) to access these tabs.

• You can verify that your camera is working (Preferences > Devices > Test Camera).
• Device tab: You can verify that your microphone and speakers are working and can set the volume to a 

comfortable level without having to actually place a phone call.
• Audio tab: You can verify that you are successfully connected to the SIP server. While you are on a phone 

call, you can test the quality of the audio.
• Support tab: If none of the above help you solve your problem, you can create logs of your activity and send 

them to customer support.

Populating your Contact List
Typically, you will want to create contacts in order to easily make phone calls, send IMs and transfer files. You 
can bring in contacts from other sources such as a CSV file, or your Microsoft® Outlook® address book. See 
“Populating the Contact List” on page 46 for all the sources. 

In addition:

• During a call that you place or receive, you can add the other party to your contact list. See “Handling an 
Established Call” on page 16.

• You can add addresses to the Contact list one by one. See page 48.

2.2 Checking for Bria Updates
If you are in an enterprise, your system administrator should tell you about the policy for checking for and 
installing upgrades. 

To check for updates to Bria, choose Help > Check for Updates. The Auto Update window appears.

• If a new version of the software is available, you can download it from this window.
• If no newer version is available, this window informs you that your version is up to date.
4
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2.3 Managing Bria Licenses
You will need to deal with license keys in the following cases.

• At initial setup, you will be asked to enter a license key if the key is not provided via provisioning.
• When you purchase an add-in for Bria, the additional key must be entered to Bria (see page 36).
• When you get a new computer, the current license keys must be transferred to the new computer.

To transfer license keys to a new computer:

1. On the current computer, start Bria and choose Help > Enter License Key. The License Key Management 
window appears.

2. Click Export Keys. The dialog appears asking which file to save the keys.

3. Name a file, and click Save. Bria creates a text file with all the keys listed. 

4. Transfer the text file to a new computer.

5. On the new computer, start Bria and choose Help > Enter License Key. 

6. Click Import Keys, and choose the text file that contains the license keys. The keys appear in the dialog.

7. Click Done. 
5
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3 Making Phone Calls

3.1 Starting and Quitting Bria
If Bria is not already running, start it as you would any other program: Use the Windows Start menu or 
double-click the desktop icon. Bria appears. To quit Bria, choose Softphone > Exit or press Ctrl-Q.

3.2 The Onscreen Softphone 
Show/hide resources such as 
contacts, favorites and modules 
such as chat rooms

Close to system tray. This icon does 
not shut down Bria

Bria menu. 
See below.

Call entry field 
See page 10.

Minimize to system tray

Change layout of contact 
list and import contacts

Toolbar. See 
page 16.

Voicemail indicator
See page 26

Missed calls 
indicator. 

Detach the tab from the main window.

Open the Messages window. 
See page 34
7
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The Bria Menu
Softphone. 

• Accounts. These settings control how Bria interacts with your VoIP service provider and are set 
individually for each account. See “Creating Accounts” on page 67.

• Preferences. These settings control the way that you work with Bria and apply to all accounts. See 
“Configuring Preferences” on page 85.

• Log Out. To log off and minimize Bria to the system tray. If you click the Bria icon in the status bar, the 
Login screen appears. This menu item does not appear if you have configured Bria for no login.

• Exit. To shut down Bria. You can also exit by pressing Ctrl-Q.
View.  Changes how Bria looks. Also lets you view the messages and chat rooms (if you are a member of one; 
see page 32).

Contacts. Lets you work with contacts. 

Help. Provides access to various service-related features. 

Compact View
To create this compact view, go to Bria, click View and hide all resources including Dialpad. 
8
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Receiving an Online Status Request
If presence is enabled, then at any time you may get an Online Status Request dialog. For information on this 
request, see “Sharing Online Status” on page 54.

 

9
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3.3 Placing a Call
Place the call as described in the table below. The outgoing call opens in its own call panel, below any other 
existing call panels. You will hear a ringing tone while Bria attempts to make a connection.

Option From the... Description

Keying Dialpad or computer 
keyboard

1. Enter the phone number in the call entry field using the dialpad or 
the computer keyboard. To turn letters to numbers, see page 12

If entering a softphone address, you can enter the entire address 
(6045551212@domainA.com) or just the number (6045551212).
As you type, a suggestion for completing the entry may appear. 
Choose the suggestion by using the Up/Down key and the Tab key, 
or keep typing.

2. Bria makes a call as soon as you choose the suggestion. If you do not 
want to choose a suggestion, finish typing and click the Call button 
or press Enter. 

Right-click a contact or 
previous call

Contacts or History tab Right-click an entry from the Contacts or History tab and choose Call.

Double-click a contact Contacts tab Contacts have a “double-click” action (page 85) that either makes an 
audio phone call or starts an IM. 

Single-click a contact Contacts tab Hover over the right side of the contact to reveal the click-to-call 
button. Click to place a call using the primary phone number for this 
contact.

Double-click a previous 
call

History tab Double-click an entry. An audio call is placed.

Redial Redial button • When the call entry field is empty, click the Call button.
• Or click the arrow in the call entry field and select a recent call. 

An audio call is placed.

Dialing Dialpad 1. If the dialpad is not visible, click the Phone button at the bottom.
2. Click the numbers on the dialpad to enter the phone number.
3. Click the Call button or press Enter.

From an instant message Messages window Click the menu at the top of the Messages window and choose Call.
10
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Dealing with an Auto Attendant

If you know that your call will be answered by an auto attendant and you know what menu items you will 
choose, you can include those menu items (DTMF) in the phone number when you dial it:

• Before the first DTMF number, include at least one capital P.
• You can include other Ps. Each P causes Bria to wait one second before sending the next character. 
• At the end of the input, you must include a ; character.

Example: To dial a number, add a 3-second delay and then press 44, enter this in the call entry field:

6045551212PPP44;

Example: To dial a number, add a 6-second delay, then press 1 then 3 then 2, each with a two second delay:

6045551212PPPPPP1PP3PP2;

A capital X or , (comma) can be used instead of P; the following will work in the same way as the first example 
above.

6045551212XXX44;

Call entry field

The Call icon. Clicking the down arrow 
gives you more call options, such as 
video call or conference call.

Auto complete suggestions. Bria makes a call as soon 
as you choose the suggestion. 
You can change this behavior so Bria does not dial until 
the Call button is pressed (page 85).

For information on working with the call, see 
“Handling an Established Call” on page 16.
11
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Selecting the Account to Use

This information applies only if you have more than one SIP account set up and enabled.

When you place a call, you can explicitly specify the account to use for that call. 

The account selection options appear only if you have two or more SIP accounts that are enabled and being used 
for phone calls. To make an account “useable” for phone calls, choose Softphone > Account Settings, select the 
account and change the Allow fields on the Accounts tab (page 70).

Letters to Numbers
You can type letters and Bria will convert the letters to numbers when placing the call:

Choose the account to use. 
This account will be used for all calls until you select a different account or go back to Auto Select.

If you choose Auto Select, then the account to 
use depends on your dial plan rules. If there 
are no dial plan rules, then the “preferred” 
account (page 69) is used.

Opens the Account list.

Type the phone number using 
numbers and letters, as desired

Turn letter-to-numbers on or off

When you click Call, the call panel will 
open and the call will be placed. The call 
panel will show the phone number all in 
numbers.
12
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Hiding your Identity (Anonymous Calling)
You can hide your identity on a call, so that the other person will not see your name or number on their phone. 
Your ID will be hidden for all outgoing calls until you turn off Hide my Number.

Anonymous calling is automatically turned off when you shut down or log off.

Placing another Call
You can place another call. On Bria, you can make up to five concurrent calls. 

Turn Hide my Number on or off

Place the call in the usual way (see page 10)

New outgoing 
call

Existing call is 
automatically 
put on hold

Switch between the different calls by clicking Resume on 
the desired call panel. That call becomes the active call and 
all other calls are put on hold. 
13
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3.4 Handling Incoming Calls
Bria must be running to answer incoming calls. It can be running in the system tray.(If Bria is not running, 
incoming calls may be directed to voicemail; check with your VoIP service provider or system administrator.)

The new call appears in its own call panel. In addition, the Call Alert box appears. For information on setting 
call alert preferences, see page 87.

   

Click. If you are on another call, that first 
call is automatically put on hold. You are 
now talking to the new caller.

Or click. There will be a busy signal. The 
call may be directed to voicemail (if you 
have this service).

Or click Forward; a call entry field 
appears. Enter the name or number to 
forward to and click Forward Now.

Click to answer a video 
call and start sending your 
video immediately

Click to answer without video; if 
you want (and if you have a 
camera), you will be able to add 
video later. 

This is the alert for a video callThis is the alert for an audio-only call
Windows 7 and Earlier

This is the alert for both audio and video calls
Windows 8 and newer

If the call is a video call (and if you have a camera), Bria will start sending 
your video upon answering. You can stop video later.
14
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Auto Answer

Disabling Call Waiting
You can turn on Disable Call Waiting. If on, when you are on a call, any new incoming call will go straight to 
voicemail or will ring as busy (to the caller). In this way, you are not distracted by incoming calls.

You can enable this feature even during a call, and it will take effect right away. The call will appear in the 
Missed Calls in the History tab.

Turn Auto Answer on or off

Auto answer is initially configured to auto-
answer after one ring, and to send only your 
audio when the call is established. To change 
this configuration choose Softphone > 
Preferences > Calls.

Auto answer is automatically turned off when 
you shut down or log off.

Disable Call Waiting on or off
A check mark indicates the feature is 
enabled (no interruption during a 
call).
15
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3.5 Handling an Established Call

Encryption
The outgoing call may be encrypted, depending on your security settings. For information on the current 
security settings, see “SIP Account Properties – Transport” on page 77.

• If an encrypted call is established, the security lock icon appears on the call display. This icon indicates that 
the call is guaranteed to be secure between you and your proxy, and may or may not be secure beyond that 
first hop. See page 77 for more details on how encryption works.

• If an unencrypted call is established, no encryption icon appears.

Add as Contact
Add the current caller as a 
contact. See “Managing 
Groups” on page 50.

Conference Calls
See page 22

Start sending video
See page 20

Mute your voice

Record the call as a 
WAV file (audio only)

Instant Message
See page 27

Place another call
The current call is automatically 
put on hold. See page 13 for more 
information

Mute speaker or adjust speaker 
volume by using slider

Use speakerphone (when yellow) 
or headset (when gray)

Transfer
See page 18

Hold and resume

You can disable call waiting. See 
the previous page.
16
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• If the call cannot be established with the specified security, the call will fail.

Ending a Call
Click the red End call button on the Call panel (the call can be active or on hold). The call panel closes after a 
few seconds.
17
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3.6 Transfering a Call

Basic (Unattended) Transfer – Transfer this Call
Click the Transfer button

The call is put on hold and a call entry field appears.

The call may end immediately.

Or it may show “calling”, In this case, do not 
hang up immediately: if the other person does 
not answer, the call will come back to you.

Then click Transfer Now. 

If the button does not show “Transfer now”, click the 
down arrow and select Transfer now. You can also 
permanently change the option that appears on the 
button; see page 85.

Type a name or number, or drag a 
contact into the field.
18
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Attended Transfer – Call then Transfer
You can first speak to the target (the person you are transferring the call to), then click Transfer Now to 
complete the transfer. 

Click the Transfer button

Type a name or number, or drag a contact into the field
Then click Call First

The call is put on hold and a call entry 
field appears

Bria phones the 
new person

You can hang up the 
second call and return to 
the first call

If the button does not show “Call first”, click the 
down arrow and select Call First. You can also 
permanently change the option that appears on the 
button; see page 85.

When you are ready, click Transfer Now. 
The call panel closes

Or if the other person does 
not want to take the call, 
click Cancel and return to 
the first call

When the other person answers, the 
Transfer Now button is enabled
19
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3.7 Handling Video Calls
Placing a Video Call
Calls made with Bria will work without a video camera, but a video camera is necessary to allow other parties to 
see your image. Bria will work with most USB video cameras.

Adding Video
If you have a camera, you can add video to a call that started as an audio call.

Click Start Video ( ) in the call panel. When you add video, the other party may (or may not) start sending 
their video to you.

Other Party Adds Video
If the other party starts their video, your video window automatically opens and the video is played. You can 

start sending your own video, if desired (and assuming you have a camera) by clicking Start Video( ) in the 
call panel.

Pausing and Resuming Video
Click Stop Video in the call panel or close the video window to pause sending your video.

Click Start Video to resume sending your video; the video window will open.

Click the down arrow and 
choose Video call

From the Dashboard

From the Contact List or History

Right-click the contact and 
Choose Video Call
20
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Status of your 
videoStart or Stop sending 

your video

Change the aspect ratio of video

To view in full screen, hover over the video window and 
click the two-way arrow icon, or press F11 when the focus 
is on the video window.

Click to configure the camera
21
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3.8 Conference Calls
This section describes how to handle conference calls hosted locally. 

Starting a Conference Call
You can start a conference call by:

• making a conference call from the dashboard, 
• adding participants to an existing established call, or
• having two established calls and merging them to a conference call.

From the Dashboard

Click the down arrow and 
choose Start Conference Call

• Enter the number or address by typing

• Or select from the redial list

Type a name or number, or drag a contact 
into the field.

Click Add. 

You can add more participants from here
22
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From an Existing Call 

Managing the Conference
 

From Two Established Calls

From One Established Call

You can add more participants

You can merge two established 
calls.

“Invite to Conference Call” will 
allows you to add a third person to 
the call with Rita.

Click the arrow for 
Participant menu 
23
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Adding More Participants
You can add more participants to an existing conference in any of these ways:

• Right-click on a contact or history item and choose Add to Conference Call.
• In the conference call panel, click Invite to Conference Call, enter a name and click Add.
• Add in a separate call that is not part of the conference call: In the call panel for the individual call, click the 

down arrow and choose Merge Calls. This call is added to the conference call.

Sending an Instant Message
Click the down arrow beside a participant name and choose Send Instant Message.

Removing a Participant
To remove one call from the conference, click the down arrow beside a participant name and choose Separate. 
The call becomes a separate call.

Ending the Conference
To hang up on everyone, choose End conference from the conference menu. 

Suspending the Conference
To suspend the conference, choose Hold from the conference menu. All participants are put on hold. 

If you need to speak to one participant separately, put the conference on hold, separate the one participant from 
the conference, take that person off hold. When done, merge the participant back into the call.
24
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Video Conference Calls
Calls made with Bria will work without a video camera, but a video camera is necessary to allow other parties to 
see your image. Bria will work with most USB video cameras.

Including Video in a Conference
When you start a conference from established calls, video is automatically included if at least one of the calls 
already includes video and is sent to all the participants.

When you start a conference from scratch, video is not included. You can open your video window and choose 
to add video at any time. Video is sent to all the participants.

How Video Is Shared
The conference host (the person who starts the conference) serves as the host for other video. Whatever the 
conference host is receiving will automatically be sent to the other parties. 

If the conference host pauses or stops video, other participants will no longer receive video.

This person has video. 

This person does not have video. To remedy this 
situation, stop video and start it again. Video will be 
sent to all the current participants.

Closing the video window stops 
sending video.

Mute. When you mute during a video call, 
you may also want to click Stop Video to 
stop the video feed.
25
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3.9 Voicemail
If your service includes voicemail and you have set up voicemail options (page 72), you can click the icon to 
automatically connect to voicemail and listen to any messages.

3.10 Forwarding Calls
Forwarding Calls
You can enable or disable forwarding so that calls will be automatically forwarded to another number. You can 
set up forwarding so that calls are always forwarded or so that calls are forwarded only when you are on another 
call.

Ask your system administrator if you should set up forwarding through Bria. It is possible that your system 
administrator has set up this feature on the PBX, so there is no need to set it up in Bria.

To enable forwarding through Bria, choose Softphone > Account Settings. Choose an account and click Edit, 
then click the Voicemail tab. For complete details, see page 72.

You can also forward a call “on the fly”. See page 14.

Voicemail icon

If you have multiple SIP accounts 
registered, clicking the voicemail 
icon reveals the number of 
messages per account.
26
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4 Presence and Instant Messaging

4.1 Instant Messaging

Sending an IM
1. You can send an IM to a contact who has a softphone or XMPP address.

2. Type the message. Include emoticons and formatting (Ctrl+B, Ctrl+I, Ctrl+U), as desired. 

To insert a return in the message, press Shift+Enter. You can control the behavior of Enter and Shift+Enter 
on the Softphone > Preferences > Application panel.

3. Click the Send icon. 

From the Contacts tab Right-click on the contact and choose Send Instant Message. The contact must 
have a softphone address.
Or click on the IM icon that appears to the right of the contact name.

An active phone call If the person is a contact, choose Send Instant Message from the call panel 
menu.

An active conference call If the participant is a contact, choose Send Instant Message from the participant 
menu.

From the Messages window Click the New Conversation icon beside the Search field, and type a number or 
name. 

Click to select more 
actions
27
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Receiving an IM
When an IM is received, either the Messages window or a Call Alert pops up. (To control which window 
appears, choose Softphone > Preferences > Alerts & Sounds.)
28
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4.2 Sending a Broadcast IM
You can send an IM to several people at one time. A broadcast IM is not a group chat: 

• With a broadcast IM, each recipient can reply to the IM, but only you will see these replies; the other 
recipients will not see these replies. 

• With a group chat, all parties see everyone’s messages and the messages each party sends are seen by 
everyone. See “Group Chat (Conference IM)” on page 30.

1. Select the parties from the Contacts tab in one or more of the following ways:

• Select one or more contacts in the usual ways (using Shift-click or Ctrl-click and/or Shift-Ctrl-click).
• Select one or more groups in the usual way.

2. Right-click and choose Broadcast IM. The New Conversation window appears. Contacts that do not have a 
softphone address will not be included in the list.

3. Type the message. Include emoticons and formatting (Ctrl+B, Ctrl+I, Ctrl+U), as desired. 

To insert a return in the message, press Shift-Enter. (You can control the behavior of Enter and of 
Shift+Enter; see Softphone > Preferences > Application.)

4. Click the Send icon or press Enter. The IM is sent.

A recipient may send you a response, which will be displayed to you in a regular Instant Message thread; 
you will then be in a regular IM with that one party.

Type a number or name to 
add more contacts. Auto 
suggestions come up.

Type a message, and click 
the Send icon.

Responses will be 
displayed in a 
separate thread.
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4.3 Group Chat (Conference IM)
Group chat allows you to exchange instant messages with a group of people in the same session. All people 
must have XMPP accounts configured in order to participate in group chat. 

There is no limit to the number of participants in a group chat session. 

Starting a Group Chat
1. In the Contacts tab, select the desired contacts. Contacts must be online.

2. Right-click the last selected contact and choose Start Group Chat. The invitation dialog appears.

3. Type a message and click the Send icon. Once a chat is started (first message has been sent), you cannot add 
or remove participants.
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Managing a Group Chat

Leaving a Group Chat
Unregistering your XMPP account or exiting Bria lets you leave all the active group chat sessions. The session 
continues with the remaining participants. Once you leave a group chat, you will not be able to rejoin the 
session. The thread in the Messages window becomes inactive (grayed out); you can read chat history, but 
cannot participate or download unread messages.

Deleting a group chat session on the Messages window also lets you leave the session, but you will lose chat 
history.
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4.4 Chat Rooms
Typically, chat rooms are used only in enterprises and are set up by the system administrator.

Chat rooms are set up to allow the same group of people to have a group IM session, usually on a regular basis. 
For example, your system administrator may create a chat room called “Marketing” and add the marketing staff 
as members. Every Monday at 8:00 a.m., each member opens the chat room on Bria and joins the conference. 

You can only use chat rooms if your system administrator has set up chat rooms and added you as a member. 
Chat rooms are only available on XMPP accounts.

1. Obtain the following information from your system administrator:

• The names of the chat rooms you belong to.
• The passwords for the chat rooms (if applicable).
• The XMPP account that must be enabled for you to use the chat room.

2. Choose View > Chat Rooms. (If the menu item does not show, make sure the appropriate XMPP account is 
enabled). The list of chat rooms appears.

 

3. Select the appropriate account if you have more than one XMPP account.

4. Select the chat room and click Join Chat Room. If prompted, enter the password for the room.
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The Messages window appears showing you and other people who have already joined to the chat room 
session. 
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4.5 Viewing Messages
To view your recent IM activity for any contact, group chat session, or chat room session, perform one of these 
actions:

• Click the Messages window icon:

• Click Shift + Ctrl +M.
• On the menu, click View > Messages. 

The session may be 
grayed out. 
Typically it means 
that the account 
used for the session 
is not registered, or 
the group chat has 
ended.

Right-click to save or 
delete a 
conversation.

You can copy the messages.Search all messages Clicking the x icon deletes the session. 
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4.6 Sending and Receiving Files

Sending Files
If you have an XMPP account, you can send files to another contact who has a Jabber address (meaning that 
they have an XMPP account). 

Choose one of these actions:

• Right-click a contact and choose Send Files; a standard Open dialog box opens. Select the files to send 
and click Open. 

• Drag a file from a folder to the IM session of the Messages window.

The Send Files dialog appears with a “waiting” message. To cancel the file transfer before the other person 
retrieves the files, click Cancel.

Receiving Files
If you have an XMPP account, another person with an XMPP address may send you files. The following dialog 
appears, to allow you to save the file.

The file is saved to the location specified in Preferences > Files & Webs Tabs. 
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4.7 Sharing your Screen
The Screen Share Add-in lets you share your screen with other people, both other Bria users and people who are 
not Bria users. You do not need to obtain the Screen Share Add-in in order to view someone else’s screen; you 
only need it if you want to share your screen.

Obtaining the Screen Share Add-in
1. To obtain the Add-in:

• If you work in an organization that has a system administrator who manages setup of applications, 
obtain the license for Screen Share from that person.

• If you do not have a system administrator, use this shortcut to go to your CounterPath Store account: 
On Bria, choose Help > Add Features. The Add-in page of the Store appears.
Follow the prompts to purchase the Add-in and obtain a license key.

2. When you have the Screen Share license key, go to Bria and choose Help > Enter License Key. The License 
Key Management dialog appears.

3. Paste the license key into the field and click Add. The key will appear in the list with a checked Status. 
Click Done.

4. Restart Bria. 

5. On Bria, choose View > Show Screen Share. The Screen Share tab appears.

Invite; see below

Start sharing; see below
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Inviting Participants
There are several ways to invite participants. Whichever method you use, people who you invited by IM and 
who are Bria users will receive the invitation as an IM in the Messages window; see page 43. Other users will 
receive a screen share link that they can click or can paste into a web browser in order to join the session.

Inviting by Selecting Contacts

You can invite people by selecting contacts from Contacts or Favorites. The contacts do not have to be Bria 
users but they must have an address that is IM-able, so either a softphone number or a SIP or XMPP IM address. 
With this method, the screen share session starts as soon as you invite someone.

If you want to share your screen with many people, you can use a contact group or group chat. 

• To invite everyone in a contact group, right-click the contact group and click Share my screen.
• To invite everyone in a group chat, click the More button in the top right corner, and select Share my screen. 

Right-click and 
choose Share 
my Screen

Choose a monitor to share, then 
click Start Sharing

The invitees appear in the 
Screen Share tab

Select one or 
more contacts

The screen share session starts 
immediately; see page 41
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Inviting by Sending an Email

You can invite any participants by email. The invitees do not need to be Bria users and do not need to be 
contacts. 

With this method, the screen share session does not start immediately, which means you can use this method to 
publish your screen share link for future use. See page 42 for more information.

Click Invite

Click email

The screen share session does not start 
immediately; you must start it manually, see 
page 41.

The Send Email dialog for your 
email editor appears.

Enter the email addresses of the 
participants and send the email.

The email is pre-populated with a 
message. You can modify this 
message, but do not delete the 
blue screen share link!

When ready, send the email
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Inviting by Sending an IM to Contacts

You can invite any participants by sending an IM to contacts you specify on the invitation. The invitees do not 
need to be Bria users. They do not need to be contacts but they must have an address that is IM-able, so either a 
softphone number or a SIP or XMPP IM address.

With this method, the screen share session does not start immediately, which means you can use this method to 
publish your screen share link for future use. See page 42 for more information.

Click Invite

Click IM

The screen share session does not start 
immediately; you must start it manually, see 
page 41

The Messages dialog appears.

Enter one or more addresses

The new message area is pre-
populated with a message. You can 
modify this message, but do not 
delete the blue screen share link!

When ready, click

The invitation
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Inviting by Copying and Manually Pasting the Screen Share Link

You can copy the screen share link to the clipboard and then send the link to invitees using whatever method 
you want. The invitees do not need to be Bria users. 

With this method, the screen share session does not start immediately, which means you can use this method to 
publish your screen share link for future use. See page 42 for more information.

Combining Methods

You can combine these invitation methods. For example, you could invite some people by email. Then you 
could invite more people by selecting from your Contacts list.

Click Invite

Click clipboard

The Messages dialog appears.
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Starting a Session
If you invite people and choose not to start the session immediately, you can start it whenever you are ready by 
clicking the Start button. Participants will see your screen as soon as they open a browser to the Screen Share 
link that you provided to them.

Click

Choose a monitor to share, then 
click Start Sharing

The screen that is being shared is 
outlined in yellow

The background color of the shared screen might change 
for the best screen share performance. It will go back to 
the original color after the session is over.
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Managing a Session
Some invitees and all participants appear in the Screen Share tab.

A person you invited in one of the other 
ways appears only after they accept the 
invitation. The name that appears is the 
name they enter in the join dialog.

A person you invited by selecting from the 
Contacts or Favorites appears in this list as 
soon as you invite them. When they accept 
the invitation, their status changes from 
Invited to Joined

To temporarily stop sharing 
your screen, click Show/Hide

To end the session, click Stop

Clicking a different tab does not end the 
session
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Managing the Screen Share Link
When you send an invitation, Bria generates a Screen Share link that includes a session ID:

http://join.softphone.com/ABCDEFGHIJKLM

The session ID portion of the link (ABCDEFGHIJKLM in the above example) is unique to you as a user. Each 
time you send an invitation, this session ID will be used. A new session ID will not be generated.

This means that you can, for example, send an invitation (using one of the methods that does not start a session 
immediately) as a future or semi-permanent invitation. 

Generating a New Session ID

Sometimes you will invite someone “outside your circle” – for example, a customer in another organization – 
and you may not want that person to be able to join future screen share sessions. In this case, you can generate a 
new link with a new session ID either at the end of the session that has the participant who is outside your circle, 
or at the start of the next invitation you make.

On the Screen Share tab, click Invite to show 
the Information dialog

Then click Generate to create a new screen 
share link

A new session ID. The old ID no 
longer lets other people view your 
screen share

Click OK to confirm
43



CounterPath Corporation
Receiving an Invitation
If you are a Bria user, you can receive an invitation to join a screen share from another Bria user who has the 
Screen Share Add-in. You do not need to have the Add-in in order to receive an invitation.

You will receive the invitation as a regular IM 
in the Messages window

Click Join

The other person’s screen appears To leave the session, close the window

To rejoin the session (while it 
is in progress), click the link 
again

If the screen share window moves behind other screens, click Ctrl-Shift-Alt-S to bring it to 
the front and in focus.
You can change this shortcut key; see page 90.
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5 Contacts

The Contacts tab displays your contacts. Each contact is shown with presence information and icons for single-
click phoning and IMing.

If the Contacts tab is not showing, go to the main menu and choose View > Show Contacts. 

Search entire contact list

You can change the detail and layout of the 
contact list: from the main menu choose 
Contacts and set the desired options

Move the list back to the main window

Contacts are typically organized into 
groups. Bria includes built-in groups. You 
can add more groups, as desired.

Add a Contact
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5.1 Populating the Contact List
At any time, but particularly when you first deploy Bria, you may want to populate the contact list with contacts 
from an external source such as a file of contacts or contacts in your Outlook address book.

Ways to populate Bria’s contact list:

• By importing contacts. See below for configuration.
• From the Microsoft Outlook Address Book. It must be 32-bit; 64-bit is not supported. See “Outlook 

Account” on page 83 for configuration. 
• From an XMPP account. See “XMPP Account” on page 81 for configuration.
• From an LDAP or Active Directory. See “Preferences – Directory” on page 93 for configuration, and see 

“Directory Tab” on page 61 for how to use it.

Populating by Importing Contacts
You can populate the Bria contact list by importing from an external file or files. Your system administrator may 
have placed a file on a server for you to import. You can also import your own file or files, as many as required. 
The new contacts will be added to the existing contacts. 

You can import a contact list from:

• CSV. A comma-separated file. Use this method to import from a Microsoft® Excel® file. You will first 
have to set up the file; see below. 

• vCard. A vCard file (*.vcf file). A vCard is an electronic business card that is often attached to an e-mail.
• PST. A Microsoft Outlook or Microsoft® Exchange contact list (a *.pst file). 

Setting up an Excel File for Import

1. Remove any introductory text or headings from the top of the file. (You can keep text at the end of the file; 
it will be ignored during the import.)

2. Insert a blank row as the first row, then insert the headings that Bria will use to interpret the meaning of 
each column. The columns can be in any order. Key headings are:

• sip-address. Bria recognizes a value in this column as a softphone address and considers the address as 
one that can be phoned and as an address that can be used for IM/presence (if SIP is being used for IM/
presence). 

• xmpp-address: Bria recognizes a value in this field as a Jabber (XMPP) address and will map this field 
to the Jabber contact method for the contact. Bria considers a Jabber address as one that can be used for 
IM/presence (if XMPP is being used for IM/presence).

• display-name, given_name, surname
• business number
• presence_subscription. Complete this column in one of these ways:

• If you only want to share presence information with some of your contacts, fill in this column in 
the file. Enter “true” for contacts whose online presence you want to see, leave blank or enter 
“false” for others. During the import, you will be able to choose to share presence with only these 
contacts. Bria will subscribe to the presence of these “true” contacts, assuming that the user has a 
SIP (if using SIP for presence).

• If you want to share presence with all your contacts (or with none), ignore this heading. During the 
import you will be able to choose to share with all (or none) of your contacts.

For a complete list of headings, see page 104.
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3. Save the file as *.csv.

Importing Contacts

1. From the main menu choose Contacts > Import Contacts. The Import Contacts wizard starts. 

2. As soon as you click Finish on the wizard, the Contacts tab in Bria is updated to show the imported entries. 

Exporting Contacts

You can export a contact list to a CSV, vCard or PST file.

1. From the main menu choose Contacts > Export Contacts. The Export Contacts wizard starts. 

2. When you click Next, the export starts. The result is:

• For a PST export, the existing .pst file is updated to include the entries from the Bria contact list. If 
Outlook is open, the entries immediately appear in the Outlook contacts. 
All information in the Bria contact list is exported to Microsoft Outlook. Only information that can be 
displayed in Outlook actually appears in the Outlook Contacts window. Typically this means that all 
softphone addresses are exported (and stored in custom fields) but not displayed in Outlook.

• For other formats, a new file of the specified type is created.
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5.2 Adding a Contact

Adding a Contact Using an Existing Address
You can add a contact by capturing existing information: 

• If you are on a phone call with a non-contact, click the Add to Contacts button in the call panel.
• On the History tab, select an entry that is not a contact. Right-click and choose Add as Contact.

The Contact Profile dialog appears. Complete the dialog as desired and press OK.

If the contact method is Softphone or Jabber, an online status request is sent to this person. See “Watching 
Others’ Status” on page 54.

Manually Adding a Contact

Click , or right-click a group and choose Add Contact to Group. The Contact Profile dialog appears. 

Field Description

Contact Summary

Display as If several display names are available, choose the one that you want to show in the contact list. 

Group Click to show the list of groups. Check each group this contact should belong to. 

Primary presence This field appears only the contact has more than one Softphone number or Instant Message address. 
The primary presence is used as follows:
• The presence icon on the contact list shows the online status for this address.
• The single-click and double-click actions for instant messaging use this address.

You can still send IMs to this person at their other addresses, but you must right-click and choose 
from the context menu.

Primary phone number If the contact has more than one number, select the primary number. This number will be used with 
single-click calling and double-click calling.

Other Sections

To enter a phone number, select 
the type, enter the number, and 
click Add

The new number appears in 
the list
48



Bria 4 for Windows User Guide
Changing Contact Information
To change the information for a contact, right-click the contact and choose Edit Profile. The Contact Profile 
dialog appears (page 48). 

Merging and Splitting Contacts
To merge contacts, select contacts and right-click to reveal the menu. Or you can drag one or more contacts to a 
contact. The dialog appears confirming that you want to merge contacts.

Moving or Deleting a Contact
• To drag one or more contacts to a different group, select them and drag to the title bar of the new group.
• To delete one or more contacts, select them, right-click, and choose Delete Contact or Delete Selected. The 

contacts are removed from this group. If a contact belongs to several groups, it is removed from all groups.

Display name (required) The display name for this source of information. For example, the display name from the XMPP 
contact list.

First name, Last name Optional.

Contact Methods Enter as many contact methods as you want. 
Enter a person’s IM address as follows:
• If you use the SIP account for IM and presence, choose Softphone.
• If you use a XMPP account for IM and presence, choose Instant Message.

If you have more than one account of a given type, include the domain (for example, 
1440@domainA.com) to ensure that the number or address gets associated with the correct account. 

Presence This field is automatically populated when you enter an address in the Softphone or Instant Message 
field. It indicates that you are sharing online presence information using this address. The address is 
also shown in the list in the Primary presence field, above.

Field Description
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5.3 Managing Groups
Bria has built-in groups. A contact must belong to at least one group.

You can perform the following actions to the group:

• Send Broadcast IM
• Start group chat
• Screenshare
• Add to Alert list
• Add to Favorites

Adding, Deleting or Renaming Groups

Select any group, right-click, and choose the appropriate menu item. 
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5.4 Using Contacts
In the Contacts tab, you can:

• Double-click a contact to phone or IM (depending on how double-clicking is configured in Preferences > 
Application).

• Click a contact to view the flyout
• Right-click to show the menu, or
• Hover over a contact to revel icons for single-click phoning or IMing.

Hover to reveal icons. Click the 
phone icon to call using the 
primary phone number. Or click the 
IM icon to send an IM using the 
primary presence address for this 
contact.

Or right-click and choose 
from the menu.

You can watch the contact’s online status, if the contact has 
a softphone or IM address.
See the table on page 56 for the meaning of the online 
status icons. 
See “Sharing Online Status” on page 54 for information on 
obtaining online status information.

See page 27

See page 30

See page 35

See page 36

See page 57

See page 60

Click a contact method to perform 
its action

Click a contact to view the flyout.
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5.5 Setting up Contacts for Presence
To see someone’s presence, you need to set up the contact information in the certain field in the Contact Profile.

In order for a contact to include a presence icon, it must be “presence-ready” and you must be subscribing to the 
contact. (“Presence-ready” means that the contact has an address that allows for presence data to be shared.)

To use presence on a SIP account, make sure that your VoIP service provider supports this service over SIP. 
:

Example – Contact with a Softphone Number

This example shows how to add a contact who uses presence on SIP.

Source of 
Contact A contact is “presence ready” if If the contact is “presence ready” and 

the presence icon still does not show

Manually entered 
or from File Import

The contact has an address in the Softphone field. Verify 
this on the Contact Profile. 
If SIP addresses are not appearing in the Softphone field and 
you initially populated the contact list by importing a file, 
the easiest solution is to fix the file and redo the import.

• Make sure the SIP account is enabled.

XMPP The contact has a Jabber address in the Instant Message 
field. Verify this on the Contact Profile. 

• Make sure the XMPP account is enabled
• Make sure you clicked the Enable XMPP 

Presence button on the Contact Profile. 
When you click this button, the Instant 
Message address appears in the Presence 
field. See below.

Outlook The Outlook contact has an address in the “softphone 
mapping” field. The “softphone mapping” field is identified 
in the Outlook Account window in “Field to use for 
Softphone address”.
Bria recognizes the “softphone mapping” field as containing 
a SIP address: an address that can be used for a phone call 
and for IM and presence via a SIP account.

• Make sure the SIP account is enabled.
• If you specified the wrong “softphone 

mapping” field, you can change it later from 
Account Settings > Your Outlook account.

Enter the person’s phone 
number in Softphone field

As soon as you add a Softphone 
entry, this field automatically 
appears. Bria will share online 
presence information with this 
person using this phone number.
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Example – Contact with an XMPP Address 

This example shows how to add a contact who has an XMPP address (for example, a Gmail address). Assuming 
you have created a corresponding XMPP account in Bria (for example, an XMPP account for your Gmail 
address), then you can send this person IMs and share online status. 

Enter the XMPP address 
in the Instant Message 
field. Include the domain 
(e.g. @gmail.com)

Click Continue to send an 
invite to this person

Or if you accidentally clear in the 
invite dialog, select the Instant 
Message entry and click Enable 
XMPP Presence

All the XMPP information moves to a 
separate section. This XMPP information 
is automatically added to your list of 
contacts on the XMPP server (for 
example, to your Gmail list)

Click Add

Finally, add the person’s phone numbers 
and other information by selecting the 
appropriate field and entering the number.
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5.6 Sharing Online Status
You can publish your online status to contacts who have softphone address, and you can set up Bria to view the 
online status of other contacts. Typical online statuses are available, on the phone, busy, and so on. 

Watching Others’ Status
To watch a contact’s status, that contact must be tagged for presence:

• If you create a contact via the Contact Profile and you include a SIP address in the Softphone field, Bria 
will automatically obtain status information for this address.

• If you create a contact via the Contact Profile and you include an XMPP address, you can click the Enable 
XMPP Presence button to obtain status information for this address.

• If you created contacts by importing a contact list, you can specify during the import whether you want to 
share presence information. See page 46.

• If you created an XMPP account in order to pull in your Gmail contacts, these contacts will already be set 
up to share status information.

• If you created an Outlook account in order to pull your Outlook contacts into Bria, then these contacts will 
be set up for presence if you set up the mapping correctly. See page 81.

When you choose to share presence information, Bria sends the contact a notification request. The request asks 
that you be able to see that person’s status. If the person allows this request, then the icon beside their name (in 
your Contacts) becomes color coded to specify their status. 

Your online status

Online status of other people

This person is either logged out or is 
not publishing their online status

This person has no icon because 
you are not subscribing to their 
online status
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Allowing Other Parties to See your Status (Publishing your Status)
Continuing from above, when the other person allows the notification request, your name is added to their 
contact list. As soon as you are added to their list, a request is sent back to you requesting that they be able to 
see your status. Bria accepts this request automatically, and the other person can now see your status.

Receiving an Online Status Request
Someone who is not one of your contacts may add you as a contact on their end, and may include your 
softphone number or XMPP address. In this case, Bria receives an online status request. 

You must respond to the request:

• Allow: This person will be added to your contact list. You can change the display name and the contact 
group for the person. This same request will automatically be sent from your Bria to the other person, so 
that you can see their online status. Because you allow the request, you will no longer be bothered by 
requests from this person.

• Ignore: The other person will not be able to see your online status. The Online Status Request may appear 
again in this session or a future session.
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Setting your Online Status

Changing your Status
Click the down arrow beside the online status indicator on Bria, and select the desired online status. 

Setting up Status Indicators
You can create a custom status indicator: click the down arrow beside the status indicator, and double-click on 
one of the existing indicators; type your custom status. 

Status Indicators
 

Indicator Meaning for your Status Meaning for Others’ Status

Available Either:
• You have set your status to this value. 
• Bria has determined that you are logged on but not on the phone or 

idle.

When you have this status, Bria will automatically detect when you 
are idle or on the phone, and change the status to match.

You can contact this person.

Busy You have set your status to this value. Bria will never automatically 
switch you out of this status; you must switch yourself.

You can contact this person.

Away You have set your status to this value. Bria will never automatically 
switch you out of this status; you must switch yourself.

You can contact this person.

On the phone Either:
• You have set your status to this value. In this case, Bria will never 

automatically switch you out of this status; you must switch 
yourself.

• You started a phone call when your status was “Available”. When 
your call finishes, your status reverts to “Available”.

You can contact this person.

Do not disturb You have set your status to this value. Bria will never automatically 
switch you out of this status; you must switch yourself.

You cannot contact this person.

Not available 
for calls

You have set your status to this value. Bria will never automatically 
switch you out of this status; you must switch yourself.

You cannot contact this person.
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5.7 Adding Contacts to the Alert List (Buddy 
Pounce)
You can add a contact to the Alert List in order to request to be notified when the online status of a contact 
changes. 

Right-click the contact or contacts and choose Add to Alert List. The Alert List icon appears beside the contact:

When the contact’s status changes, a notification appears.

Idle You have not moved or clicked the mouse or pressed a keyboard key 
for the Idle period. To set the Idle period see Softphone > Preferences 
> Application.
As soon as you click the mouse or keyboard, your status changes to 
“Available”.

You can contact this person.

Appear offline You have set your status to this value. The other person sees you as 
offline, even though you are actually online. The other person cannot 
tell the difference between this status and you really being offline.

The contact is either not logged on 
or does not want to share online 
status. 

No icon Not applicable You are not watching the other 
person’s status.

Indicator Meaning for your Status Meaning for Others’ Status

Alert List icon

The time at which the 
contact’s status changed

Click to keep the contact on the alert list; the next time the 
contact’s status changes, another notification will appear.
Or leave unchecked to stop receiving notifications.

Click to phone or IM this 
person
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6 Using Other Resources

6.1 History Tab
To view the History tab, go to the main menu and choose View > Show History.

Managing the Lists of Calls
You can right-click on an entry in a list to:

• Delete the entry.
• Delete all entries in the list.
• Edit the profile if the entry is a contact.
• Add as contact. The Contact Profile appears (page 48).

Phoning from History
You can:

• Right-click on an entry to place a call to this person, using the contact method that was used for this call. 
• Double-click to place an audio call.
• Place a call to this person and add them to a conference call that is in progress. For more information on 

conference calls, see page 22.

Filter list

Down arrow: Incoming call 
that was answered

Up arrow: Outgoing call, 
either attempted or 
established

Attach to main window

Red: Incoming missed call
59



CounterPath Corporation
6.2 Favorites Tab
You can create favorites from your contact list. They will be displayed in both the Contacts tab and in the 
Favorites tab.

Select the desired contacts, then right-click and choose Add to Favorites.

To view the Favorites tab, go to the main menu and choose View > Show Favorites.

You can perform nearly all the same actions 
on the contact in the Favorites tab as you 
can in the Contacts tab.

Removes from Favorites but does not remove 
from the contact list

Removes from Favorites and the contact list
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6.3 Directory Tab
The Directory tab is available only if your system administrator has set up Bria to access a corporate directory. 

To view the Directory tab go to the main menu and choose View > Show Directory.

Phone a Person
Right-click an entry and choose Call or Video Call. The call is placed immediately. 

Create a Contact
Right-click an entry and choose Add as Contact. The Contact Profile window appears, populated with all the 
information from the directory (not only the information displayed in the tab). 

Complete the window with any missing information that you want to record and press OK.

When you have “contacts created from directory”, the contacts are:

• Automatically updated whenever the corresponding directory entry changes. 
• Automatically deleted if the corresponding entry is deleted from the directory.

You can delete the contact. Only the contact is deleted; nothing happens to the entry in the directory.

Only one number appears for each entry. 
There may be other numbers that will 
show if you try to call this person.
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7 Troubleshooting

Choose Help > Troubleshooting to display the Troubleshooting window. 

7.1 Testing Audio Devices
You can verify that your microphone and speakers are working and can set the volume to a comfortable level 
without having to actually place a phone call.
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7.2 Testing Audio Quality
While you are on a phone call, you can test the quality of the audio. Note that to perform a valid test, you should 
be on an established call (not a call attempt). 
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7.3 Diagnostics - Sending a Log
If you have contacted CounterPath Customer Support in order to troubleshoot a problem, you may be asked to 
generate a diagnostic log and send it to CounterPath. 

• You can also view the latest log by clicking the View Log button. 
• Bria displays reference numbers of previous logs. This could be helpful when you talk to Customer 

Support. Although you cannot view these previous logs from Bria, the customer support representative can 
view them on the log server by using the reference numbers.

1. Change the log 
level to Verbose

4. Provide a 
description.

5. Click to send.

2. Perform the 
actions you want 
to capture. For 
example, if you 
have an one-way 
audio, make a call 
in the same way as 
you experienced 
the issue.

3. Send a log. 
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Configuring Bria

8 Configuring Accounts

Bria has two configuration parts: account settings and preferences. The Account Settings window lets you 
configure features that apply on a per-account basis. The Preferences window, on the other hand, lets you 
configure features that apply across all accounts.

There are three types of accounts in Bria. 

• SIP account - a user needs at least one SIP account in order to make phone calls.
• XMPP account - for presence and instant messaging.
• Outlook account - for pulling Outlook contacts into Bria.

8.1 Creating Accounts
SIP Accounts
Each user will need at least one SIP account, in order to make phone calls. The SIP account may also be used 
for presence (online status sharing) and instant messaging; it is subject to your VoIP service provider.

Each user requires the following information in order to register with the SIP registrar:

• User name and domain. For example, 1331@domainA.com.
• Password
• Authorization Name (if applicable)
• Firewall traversal and other network information; see page 74.

Create SIP Account

1. When the softphone appears, click the Go to Account Settings link. The SIP Account window appears.

2. In the Account tab, complete all the User Details fields.

3. Complete the remaining tabs as specified by your service provider or to suit your setup. Settings that you 
may need to change immediately include:

• Account tab, Domain Proxy area.
• Topology tab, if your computer is on a network and/or behind a firewall.
For more information, see page 70.
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4. When done with the SIP account, click OK; the account is created and registered (enabled). 

XMPP Accounts
Setup of an XMPP account is optional; if it is set up, it will automatically be used for presence subscriptions and 
instant messaging. End users can pull their contacts into the Bria contact list, and then IM these contacts directly 
from Bria. Several XMPP accounts can be created and enabled concurrently. 

Each user requires the following information:

• Jabber ID: user name and domain. For example, jsantos@domainXMPP.com.
• Password
• Connection information; see “XMPP Account” on page 81.

Create XMPP Account

1. Choose Softphone > Account Settings. The Account Settings window appears.

2. Click Add > XMPP Account. The XMPP Account window appears. 

3. Complete the window and click OK. 

4. On the Account Settings window, click Apply to register the account. Click OK when the Status column is 
“Ready”. In a few seconds you will see all the existing contacts from your XMPP account appear in the 
Bria contact list, in a new group.

8.2 Setting up Multiple SIP Accounts
You can set up Bria so that phone calls can be made from more than one account. 

Decide how you want Bria to choose the account to use for any given phone call. There are two options:

• Dial plan decides: The dial plans must be designed so that they select the appropriate account, based on the 
phone number being dialed. You can still designate one account as the “preferred” account; this account 
will only be used if none of the dial plan rules apply to a given phone number. 

• User selects: With this option, you do not need to revise the default dial plans. Instead, the user can select 
the account to use for any given call, as described in the user guide. You must advise users on which 
account to use for which kind of phone call. For example, “use Account 1 for internal calls”. 

If you are a system administrator and implementing “Dial plan decides”, modify the dial plans as required. See 
the Bria Dial Plan Guide, available on the CounterPath website. Advise users whether they should use the 
account selection feature – probably they should not, but this is your decision.
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8.3 Accounts Settings Window
Choose Softphone > Account Settings from the menu. The Account Settings window appears, showing all the 
accounts currently set up. From this window you can add (create), enable or disable, edit, or remove a SIP, 
XMPP or Outlook account. 

 

The Call column indicates how the account is use for phone calls:

The account is the “preferred account”.

The account can be used for phone calls by selecting it on the dashboard (page 12) if the account is 
enabled/registered.

Empty The account cannot be used for phone calls because it is either a non-SIP account or a SIP account 
with calling disabled.

Your “corporate” SIP account

This account will be used for calls if Auto Select is used (page 12) and there 
are no dial plan rules for selecting the account

Your own Jabber account

Here is a typical setup

Another SIP account

An Outlook account. This account is automatically created for 
you in some situations; see page 81.

Your “corporate” XMPP account
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8.4 SIP Account

SIP Account Properties – Account

Table 1: SIP Account Properties – Account

Field Description
Account name If desired, change the account name to something that is meaningful to you. For example, the 

name of the VoIP service provider.
Protocol Read-only. Always specifies SIP.
Use for Call If checked, this account is eligible to be used for phone calls. If unchecked, this account will 

never be used for placing phone calls.
Use for IM/Presence If checked, this account is eligible to be used for IM and online status (presence). If 

unchecked, this account will never be used for IM and online status.

User Details
User ID Typically the account number for the softphone account. For example, 6045551212 or 2766. 

Provided by your VoIP service provider. 
Domain For example, domainA.com. Provided by your VoIP service provider.
Password Provided by your VoIP service provider.
Display name This name is displayed in the Bria title bar.

Other people will see you as this name.

Fields with a red asterisk are required
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Authorization name May not be required. If it is required, it will be provided by your VoIP service provider.
Typically not used in an enterprise environment. This name is useful if, for example, you 
allow user IDs that are short and therefore easy to guess. The authorization name is used in 
place of the user name to register the account with the SIP registrar. 

Domain Proxy
Register with domain and receive 
calls

Check this box if you want to register with your VoIP service provider, so that you can receive 
incoming calls.
Typically, this field is checked. 
This field must be left unchecked if, for example, your level of service does not include the 
ability to receive incoming calls. (In that case, turning this field on may cause the account to 
fail to be enabled). 

Send outbound via Choose the setting specified by your VoIP service provider: 
• Domain: If your VoIP service provider requires that traffic be directed to proxies that are 

discovered via the domain.
• Proxy: If your VoIP service provider has an outbound proxy address and requires that you 

provide the address to Bria. For the address, enter a domain name (for example, 
domain.com) or an IP address (for example, 123.456.789.012). 

If neither of these settings is suitable, see page 79 for a third way to direct traffic.
Dial Plan Information about the syntax of the numbers used by this VoIP service provider. 

Provided by the service provider. The default plan is:
#1\a\a.T;match=1;prestrip=2;
You do not need to change the default dial plan if:
• You have only one SIP account.
• You have multiple SIP accounts, but you will always manually select the account to use for 

calls. 
• The default dial plan is acceptable.

See the Bria Dial Plan Guide on how to configure dial plans.

Table 1: SIP Account Properties – Account

Field Description
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SIP Account Properties – Voicemail

This panel lets you configure client-side voicemail.and client-side call forwarding. You can set up Bria to 
interact with your VoIP service provider’s voicemail service. You also can configure Bria to forward calls in 
several situations, independent of your VoIP service provider’s voicemail service.

If you have a Subscription from a VoIP Service Provider
Your VoIP service provider may provide the ability to set up for voicemail outside of Bria (server-side 
handling), for example, by phoning a softphone address and following the voice prompts, or by accessing a 
website. Check with your service provider to determine if another setup mechanism is available. If so, check 
what the settings are in that setup, and make sure you enter compatible information in Bria. In particular, if your 
service provider has a mechanism for call forwarding, find out if you should leave the Forwarding settings on 
this Voicemail tab blank.

If you are a System Administrator Managing IP PBX
Your IP PBX may also provide the ability to configure voicemail (server-side handling). An incoming phone 
call first goes through server-side handlers and then through the client-side handlers. Keep in mind that the 
fields on this Voicemail tab are not written to the server; they are configuring a second, separate handler.
You must decide how you want phone calls to be handled: by the server only, by the Bria client only, or by both. 
Instruct your users accordingly. If you decide to allow both, you must make sure that your users understand how 
the server-side and client-side voicemail configuration must be synchronized to work together. You must also 
check what the server-side settings are and make sure you enter compatible information in Bria. 
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Table 2: SIP Account Properties – Voicemail

Field Description
Check for voicemail Set the checkbox in one of these ways:

• Check the box if Bria must subscribe to be notified when there is a voicemail for 
you. In other words, to configure for “subscribe for message waiting”.

• Clear the checkbox if the service provider’s voicemail server sends notifications 
without Bria subscribing. In other words, to configure for “implicit subscription”.

• Clear the checkbox if the service provider does not support voicemail. 

Check with your VoIP service provider/system administrator for the correct 
configuration.

Voicemail is offered by your VoIP service provider, or your enterprise’s IP PBX; it is 
not part of Bria. Contact your service provider/system administrator for information on 
using voicemail.

Number to dial for checking voicemail Optional, but complete this field only if your VoIP service includes voicemail. This is 
the number that will be called when a user clicks the Check for voicemail icon on the 
softphone, in order to connect to voicemail and listen to messages.
• Completing this field activates the voicemail icon on the softphone. When you click 

this icon, Bria will dial this number. You will be connected to your service provider’s 
voicemail and can listen to your messages. 

• If you leave this field empty, then this icon will not work; you will have to manually 
dial this number in order to connect to voicemail.

Enter the number provided by your VoIP service provider/system administrator.
Number for sending calls to voicemail Complete only if your VoIP service includes voicemail. Optional, but you must 

complete it if you check “Send calls to voicemail if unanswered”.
This is the number that incoming calls will be forwarded to if they are unanswered after 
the specified interval (below).
If you leave this field empty, then Bria will never forward calls to your service 
providers’ voicemail. However, most VoIP service providers have their own mechanism 
for sending unanswered phone calls to voicemail. So leaving this field blank does not 
mean that forward-to-voicemail does not work. 
Enter the number provided by your VoIP service provider/system administrator.

Send calls to voicemail if unanswered Complete only if your VoIP service includes voicemail.
To send to voicemail after the specified number of seconds. 
Your service provider may also provide a similar feature that is set up outside of Bria. If 
so, make sure you do not enter competing information in Bria and in the service 
provider’s user interface. For example, if you turn off this field, make sure the same 
feature at your service provider is also turned off. Otherwise, all your calls will continue 
to be forwarded.

Always forward to this address You can use this feature even if your VoIP service does not include voicemail.
To always forward phone calls, click the box and enter the address to forward to. Phone 
calls received on other accounts (if you have them) are not affected by enabling this 
field. 
Always forward works only when Bria is running and only if your VoIP service 
provider supports redirect.

When on the phone, forward to You can use this feature even if your VoIP service does not include voicemail.
To forward only when you are on another phone call, click the box and enter the address 
to forward to. Phone calls received on other accounts (if you have them) are not affected 
by enabling this field. 
Always forward works only when Bria is running and only if your VoIP service 
provider supports redirect.
Your service provider may provide a similar feature that is set up outside of Bria. If so, 
make sure you do not enter competing information in Bria and in the service provider’s 
user interface. For example, if you turn off this field, make sure the same feature at your 
service provider is also turned off.
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SIP Account Properties – Topology

Table 3: SIP Account Properties – Topology

Field Description
Firewall traversal mode Choose the setting recommended by your VoIP service provider:

• Auto detect using ICE: Automatically determine the contact address for signaling 
traffic.

Advertise the local IP, public IP (discovered via STUN, if available) and media relay 
IP and use these to automatically determine the best route for media traffic during 
calls.

• Discover public IP address: Advertise the public IP address (discovered via STUN) for 
the contact address for signaling traffic, and for the connection address for media 
traffic.

• Use media relay (TURN): Advertise the public IP address (discovered via STUN) for 
the contact address for signaling traffic.

Advertise the address of a media relay server (discovered via TURN) for the 
connection address for media traffic.

• None: Advertise the local IP address only for both signaling and media traffic.
Server address • Empty: Discover the address of the firewall traversal server (the STUN or TURN 

server), if available, using DNS SRV. 
• Specified: Use the firewall traversal server specified as either an IP address or a fully 

qualified hostname.

If you use the “Auto detect using ICE” option, then you can only enter a STUN server 
here. Don’t enter a TURN server because when ICE is used, TURN is not supported.
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Port Ranges You can set a range of ports on local computer for SIP signaling, RTP audio and video. 
The appropriate setting depends on your computer setup:
• Checked: If your computer is behind a restrictive firewall that only allows specific 

port ranges to be used. Enter the range of ports to use for your SIP account. (You must 
also open those ports on your firewall; refer to applicable firewall documentation for 
information.)

• Unchecked: If your computer is not behind a restrictive firewall.   

Table 3: SIP Account Properties – Topology

Field Description
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SIP Account Properties – Presence

This tab lets you configure presence.

Presence
Presence allows other softphone users to see your online status and allows you to see the online status of others. 

This tab lets you configure how online status is handled for contacts who have a softphone number on your SIP 
account. (Note that you do not have to configure online status for XMPP accounts; it always works the same 
way with these accounts.) 

Table 4: SIP Account Properties – Presence

Field Description

Presence
Mode Peer-to-peer
Poll time Enter the value specified by your VoIP service provider. 
Refresh interval Enter the value specified by your VoIP service provider. 
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SIP Account Properties – Transport

Encryption
You can set up Bria for the type of security (encryption) you want for incoming and outgoing calls.
Bria supports:
• Signaling encryption using TLS
• Media encryption using SRTP.

Setting up for Security outside of Bria
When using TLS, you must have the root certificate that signs the proxy's chain of certificates. In most cases, 
the root certification will already be installed. Procedures for the exchange of certificates are outside the scope 
of this documentation. The certificates must be stored on the Bria computer, in the root certificate store.
Setting up the root certificate on your computer ensures that the connection to the proxy is TLS secure (the first 
hop). Any proxy in the chain (between you and the caller) that does not support TLS may cause an insecure link 
in the chain. Therefore, if the other party is outside your domain, you cannot be completely sure that the call is 
secured at the signaling level, which means that you cannot be sure that it is secured at the media level.

Table 5: SIP Account Properties – Transport

Field Description
Signaling Transport Contact your VoIP service provider to identify the types of transport that are supported. 

Then choose a supported transport:
• Automatic: Bria sets up the transport based on the capabilities of the network and the 

Bria computer. Choose this option if you do not care which transport is used.
• TCP: This transport provides no signaling security. 
• UDP: This transport provides no signaling security. 
• TLS: Choose this option to request signaling encryption or both signaling and media 

encryption.
Encryption See the description below for more information.
Enable IPv6 Generally, leave this enabled. Disable it only if advised to do so by your VoIP service 

provider or your system administrator.
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Setting up for Security within Bria
The options for media encryption are described in the following table.

Table 6: Security Options

Option How Outgoing Calls are Handled How Incoming Calls Are Handled
Make and accept only 
encrypted calls

Bria will place all calls with TLS. The call INVITE 
will specify SRTP media encryption. 
If the correct certificates are not in place or if the 
other party does not accept encrypted calls, the call 
will fail.

Bria will only accept INVITEs that are for 
encrypted calls. 
If Bria receives a call INVITE that is not 
encrypted, the call will be rejected.

Do not allow encrypted 
call

Bria will place only unencrypted calls.
If the other party does not accept unencrypted 
calls, the call will fail.

Bria will only accept INVITEs that are for 
unencrypted calls. 

If Bria receives a call INVITE that is encrypted, the 
call will be rejected.
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SIP Account Properties – Advanced

Table 7: SIP Account Properties – Advanced

Field Description

Register Settings
Reregister every The time interval between Bria’s attempts to reregister in order to refresh the account registration 

with the VoIP service provider for this account. A value of zero means not to reregister after the 
initial registration.
This value is placed in the “Expires” header field of the REGISTER message.

Minimum time If the reregistration fails, Bria will wait this amount of time, then attempt to reregister. If the 
second attempt fails, Bria will wait twice this time and try again, then four times this time, and so 
on, until reregistration succeeds.

Timers
Enable session timers
Default session time

A session timer is a mechanism to detect whether a call session is still active from the signaling 
point of view. When the timer expires, a refresh is sent from one party to the other. The timer is 
then reset.
• Turn on to enable session timer. Enter a value in Default session time. 
• Turn off to disable session timer; refreshes will never be sent.

Session timer preference This field specifies how Bria uses session timers. The choices are:
• Inactive. Session timers will not be used in any session, except when it is explicitly required in 

the remote request.
• Optional. Session timers will be used in all sessions whenever the remote party supports and 

uses it.
• Required. Session timers support will be a requirement for the remote party to be able to 

establish a session.
• Always. Session timers will always be used in all sessions, regardless of whether or not the 

remote party supports/uses it.
Hold Method Change this setting only if your VoIP service provider advises you to do so.
Send SIP keep-alives Typically on, to instruct Bria to send SIP keep-alive messages in order to maintain a “pinhole” 

through your firewall for SIP messaging.
Use rport Typically on.
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Use outbound When checked, requests always go to the outbound proxy configured in the “Send outbound via” 
field on the Account tab (page 70); in other words, Bria never sends the invite directly to the 
endpoint.
If you check this field, make sure you also set the proxy in the “Send outbound via” field.
Typically off. Enable this setting only if you have trouble connecting to the SIP server.

Table 7: SIP Account Properties – Advanced

Field Description
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8.5 XMPP Account
You create an XMPP account if:

• Your enterprise uses XMPP for presence. 
• You already have an XMPP account independent of Bria (for example, a Jabber account). When the 

account is created, those contacts are pulled into the Bria contact list. You can then IM these contacts 
directly from Bria.

Table 8: XMPP Account Properties – Account

Field Description
Account name If desired, change the account name to something that is meaningful to you. For example, 

“Corporate account”.
Protocol Read-only. Always specifies XMPP.

User Details
User ID The XMPP (Jabber) user ID. For example, jsantos. Provided by the XMPP service provider.
Domain For example, domainXMPP.com. Provided by the XMPP service provider.
Password Provided by the XMPP service provider.
Display name This name is displayed in the Bria display. Other parties may see this name when they are 

connected to you.

Advanced
Port selection Configures the port to use. If you choose “User selected”, complete the Connect port field. 
Connect port Complete only if Port selection is set to “User selected”

Fields with a red asterisk are required
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Outbound proxy The value in User ID and in this setting may be used by Bria to compose a valid jid:
• If User ID=bob@ABC.com and Outbound proxy is empty, jid=User ID: bob@ABC.com
• If User ID=bob@ABC.com/home and Outbound proxy is empty, jid=User ID: 

bob@ABC.com
• If User ID=bob@ABC.com and Outbound proxy=XYZ.com, ignore the Outbound proxy; 

User ID=bob@ABC.com
• If User ID=bob@ABC.com and Outbound proxy=IP address or host address, jid=User ID. 

(IP address is used as the outbound proxy).
• If User ID=bob and Outbound proxy=ABC.com, jid=bob@ABC.com.

Resource Optional resource, as specified in RFC 3920. For example “/home”. If this setting is blank and 
the User ID includes a resource, the value from that ID is used. If both are specified, the value 
from this Resource field is used. If no resource is specified, the XMPP server will assign a 
temporary resource.

Priority The priority, as per RFC 3921. The default is 0.

Table 8: XMPP Account Properties – Account

Field Description
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8.6 Outlook Account
Bria automatically creates an Outlook account if it detects 32-bit Outlook on the user’s computer. The account 
is disabled by default. If the account becomes enabled, the contacts from that Outlook address book will be 
pulled into Bria. Enabling this account is therefore a mechanism for populating the contact list. 

The Outlook account is supported only with 32-bit Outlook. You can enable the Outlook account if you 
are using 32-bit Outlook. If you are using 64-bit Outlook, you will see the Outlook account grayed out 
and will not be able to enable it. 

If you are using 32-bit Outlook and get this error message, make sure that your Outlook is configured correctly:

The user can enable the Outlook account to provide Bria with access to the contacts in their address book. 
Furthermore, the user can map contact addresses to Bria contact fields in order to make the addresses “phone-
able” or “IM-able”: contact mappings can be created in the Outlook Account dialog.

Table 9: Outlook Account Properties – Account

Field Description
Outlook profile Typically, you only have one profile, which Bria detects.

However, if your Outlook is set up on this computer with more than one profile, select the 
profile whose contacts you want to access.

Profile password The password for the selected Outlook profile. 
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Field to use for Softphone 
address

Bria can be set up to treat one of the contact fields as a SIP address that can be subscribed to, 
assuming that you are using your SIP account for presence.
For example, if you select “Business Telephone Number” in this field, then when contacts are 
pulled into Bria, any Business Telephone Number fields that have a value will be copied to the 
Softphone field in the Bria contact and Bria will subscribe to the online status of that contact via 
your SIP account.
For example, if an Outlook contact has “2766” in its Business Telephone Number field and 
your SIP account is domainA.com, then Bria will subscribe to 2766@domainA.com.

Field to use for IM address Bria can be set up to treat one of the contact fields as an XMPP address that can be subscribed 
to, assuming that you are have an XMPP account set up in Bria.
For example, if you select “IM address” in this field, then when contacts are pulled into Bria, 
any IM Address fields that have a value will be copied to the Instant Message field in the Bria 
contact. Bria will subscribe to the online status of that contact via your XMPP account. 
For example, if an Outlook contact has “kperera11@gmail.com” in its Instant Message field 
and you have a Gmail account set up in Bria, then Bria will subscribe to kperera11@gmail.com

Table 9: Outlook Account Properties – Account

Field Description
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9 Configuring Preferences

Choose Softphone > Preferences. The Preferences window appears. 

The Preferences panels let you control the way that you work with Bria. It also contains fields to configure 
features that apply globally, rather than on a per-account basis.

Preferences – Application

This panel lets you set your preferences for general GUI behavior and lets you set up for login.

Login Options
Login is typically used only in enterprises, and requires a login/provisioning server. 

The “Enable login screen” field is used only when you started up Bria with the “No login required” profile 
(page 3) but in fact you do need to log in. To recover from this mistake:

• Check this field and shut down Bria
• Start Bria again. The Bria Login dialog will appear. Select the correct option and log in. 
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Default Actions
This feature lets you control the action performed for two buttons:

• The green Call button at the top of the phone. For example, you can configure the button so that it makes a 
video call instead of an audio call.

• The transfer button. For example, you can configure the button so that it initiates unattended (transfer now) 
transfer instead of an attended (call first) transfer.
86



Bria 4 for Windows User Guide
Preferences – Alerts & Sounds

The tabs on this panel let you control the Call Alerts box and lets you assign sounds. 

Alerts

You can control whether the Call Alert box is displayed in different situations. 

You can also control how you are alerted to an incoming IM: either with a small IM Alert box or with the 
Messages window itself.

Sounds

You can assign specific sounds to a variety of actions or “events”.

1. Select the Enable sounds check box and select the check boxes for each desired event, or clear the Enable 
sounds check box to disable all sounds.

2. You can change the sound for each event: select the individual event. The value in Sound preference will 
change. Select the desired sound.

You can import sounds; these will be added to the list of sounds you can choose from when assigning a sound to 
an event.

Windows 7 Windows 8 and 10
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Preferences – Devices

Bria automatically detects devices at each startup, and selects the most appropriate device for each purpose. If 
you do not like this selection, you can override it on this panel.

If you override a selection, it will apply the next time you start Bria, unless the device is no longer available, in 
which case Bria will again select the device to use.

Table 10: Preferences – Devices

Field Description

Automatic gain control On to automatically adjust the audio gain.

Reduce background noise Automatically attempts to remove background noise.
Typically on for the speakerphone.

Test Devices For information on the Test Devices button, see page 63.

Test Camera Click to check if Bria can use your camera. The video window opens, and shows a message.

Headset Mode

Speaker 
Microphone 

Change these fields only if you want to override the devices that Bria automatically selected.
In both these fields, select the headset you are using.
The headset is the device that is usually used for the speaker (the sound you hear) and microphone 
(recording your voice). The only situation in which the headset is not used is when the Speaker 
Phone button on the dialpad is pressed. 
Therefore, unless you will always be using Bria in speakerphone mode, you must make a selection 
here.
Select the headset in both the Speaker device field and Microphone device field.

Speakerphone Mode

Speaker 
Microphone 

Same as headset mode, but for the device to use when speakerphone is one (on the toolbar). 
Select None if you do not have a speaker phone. The Speaker Phone button on the dialpad will be 
disabled.
You can set different devices for the speaker and microphone: for example, you can set the speaker 
to the speakerphone and set the microphone to your headset.

Reduce echos Turning this feature on improves sound quality. This feature is typically on.
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Other Device

Ring On Change this field only if you want to override the devices that Bria automatically selected.
The device where you want to hear the phone ringing: the headset, the speakerphone, or none.

Camera This field appears only on versions of Bria that include video functionality.
Change this field only if you want to override the devices that Bria automatically selected.
Select the camera model.

Max Resolution Leave at standard, or change the size as follows:
• Set it to high if you have a good camera and a computer with a fast CPU. You will know that you 

have set the size too large if:

Your computer slows down (the video is using too much CPU)
The video shows black areas or is slow or jerky.

• Typically set it to low only in special situations, for example, when using Wi-Fi in a hotel. You 
will know that you have set the size too small if the video is fuzzy.

Table 10: Preferences – Devices

Field Description
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Preferences – Shortcut Keys
You can enable shortcut keys to several functions. 

Customizing the Shortcut Key Combinations

You can change the default key combinations.

1. Make sure Enable shortcut keys is checked and the action you want to change is enabled.

2. Select an Action and click Edit. The Edit Shortcut Key dialog appears.

3. Make sure there is a checkmark in the keys you want to use. You must 
turn on at least two keys.

4. Type the desired letter or number in the field. For example, the following 
creates the shortcut combination Shift-Alt-U.

The following rules apply:

• You cannot override standard Microsoft Windows combinations such as Ctrl-Alt-Delete.
• The shortcut applies when Bria is running, regardless of the application that is in focus. For example, if Bria 

is running but another application has focus, pressing Ctrl-Alt-Shift-A will answer an incoming call.
• If another application has the same shortcut combination, then which application was started later has 

control over that combination.
• If the shortcut is not valid at a particular moment, then it has no effect. For example, pressing Ctrl-Alt-

Shift-A has no effect if there is no incoming call in Bria.

Click to enable shortcut 
keys.

Then make sure the 
individual actions are 
enabled
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Preferences – Audio Codecs

This panel shows all the codecs that are included in the retail version of Bria. You can enable or disable codecs 
as desired. With only one codec enabled, all calls made will use that codec. With more than one codec enabled, 
Bria offers the enabled codecs and negotiates a common codec with the other party.

You cannot change the properties of any codecs.

About Codecs
Audio codecs describe the format by which audio streams are compressed for transmission over networks. 
Codecs can be categorized as either narrowband or wideband:

• Narrowband codecs work with low bandwidth such as a dialup internet connection. These codecs have a 
sampling rate of 8 kHz.

• Wideband codecs work with high bandwidths and result in better audio quality. However, they do not work 
with PSTN. These codecs have a sampling rate of 16 kHz.
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Preferences – Video Codecs

Video codecs describe the format by which video streams are compressed for transmission over networks. Some 
codecs require less bandwidth than others, but may result in lower video quality.

You can enable or disable codecs as desired. You may decide to disable a codec even though your VoIP service 
provider supports it.

With only one codec enabled, all calls made will use that particular compression format. With more than one 
codec enabled, Bria offers the enabled codecs and negotiates a common codec with the other party. 

You cannot change the properties of any codecs.
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Preferences – Directory
If your organization has an LDAP or Active Directory server, you can configure Bria to connect to that server. 
The entries from the directory will appear in the Directory tab (alongside the Contacts and History tabs). 

LDAP

LDAP Settings

Field Description

Server Settings

Server The hostname or IP address of the directory server. For example, ldap.example.com.

Authentication method Anonymous or Simple.
Choose Simple if your LDAP server requires a valid login in order to allow binding and searching 
the directory.

Username The full DN of the username that will be used for authenticating to the directory. 
For example:
CN=ldapauthuser,OU=users,OU=company,DC=example,DC=com
Leave blank if Authentication is set to Anonymous.

Credential The password for the username. Leave blank if Authentication is Anonymous.

Root DN The “base” DN of the server where searches will begin. The entire subtree under the Root DN will 
be used for searching. For example:
OU=users, OU=company, DC=example,DC=com

Search expression The query used to filter valid users in the directory. This query can be used to retrieve only 
members of a group, for example. For example:
(memberOf=CN=Corporate Users, Ou=Groups, OU=company, DC=example,DC=com)
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Search Options

Type • Search on demand: The Directory tab on the softphone will have a Search button. The 
Directory tab is empty until the user performs a search. Each time the user clicks Search, a new 
retrieve is performed. This option is recommended for directories with more than 500 entries.

• Type to filter list: The Directory tab on the softphone will not have a Search button. The 
Directory tab is populated as soon as Bria starts, with the records from the database (restricted 
by the Max records field. When the user types in the filter field in the Directory tab, the local 
contents are filtered (a new retrieve is not performed).

Search timeout A search of the database will stop if it has not succeeded by this timeout. 

Max results Optional, to restrict the number of records returned. 
• When “Search on demand” is chosen, this field can be used to prevent the user retrieving too 

many records (and slowing down the system).
• When “Type to filter” is chosen, make sure this number is at least equal to the number of 

records in your database, otherwise records at the end of the database will never be retrieved.

0 means no maximum number of records. 

Update interval When “Type to filter” is chosen, the database is retrieved with this frequency. If the user has 
filtered the Directory contents, then when this timer expires, the filter is lost and the entire 
database is displayed again.

Attribute Mapping

All fields The Attribute Mapping panel is used to map the attributes that are in your directory to the 
corresponding fields in Bria. The panel shows the Bria fields that appear in the Contact Profile. 
Enter the attribute names that are in your directory; for example, if your directory stores mobile 
numbers as the “cell” attribute, enter cell in the Mobile number field. 
Be careful with this mapping because when users create a contact from a directory entry, Bria will 
allow/disallow certain functions (such as sending an IM) based on whether a given "contact 
method" is populated. Specifically:
• Softphone: Bria recognizes a value in this field as a softphone address and will map this field to 

the Softphone contact method for the contact. Bria considers a Softphone address as one that 
can be phoned and (if SIP is being used for IM/presence) as one that can be used for IM/
presence.

• Jabber: Bria recognizes a value in this field as a Jabber (XMPP) address and will map this field 
to the Jabber contact method for the contact. Bria considers a Jabber address as one that can be 
used for IM/presence (if XMPP is being used for IM/presence).

LDAP Settings

Field Description
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Active Directory

ADSI (Active Directory) Settings

Field Description

Server Settings 

Subtree DN The Active Directory subdirectory to restrict the search to.

Search Options

Type • Search on demand: The Directory tab on the softphone will have a Search button. The 
Directory tab is empty until the user performs a search. Each time the user clicks Search, a new 
retrieve is performed. This option is recommended for directories with more than 500 entries.

• Type to filter list: The Directory tab on the softphone will not have a Search button. The 
Directory tab is populated as soon as Bria starts, with the records from the database (restricted 
by the Max records field. When the user types in the filter field in the Directory tab, the local 
contents are filtered (a new retrieve is not performed).

Search timeout A search of the database will stop if it has not succeeded by this timeout. 

Max results Optional, to restrict the number of records returned. 
• When “Search on demand” is chosen, this field can be used to prevent the user retrieving too 

many records (and slowing down the system).
• When “Type to filter” is chosen, make sure this number is at least equal to the number of 

records in your database, otherwise records at the end of the database will never be retrieved.

0 means no maximum number of records. 

Update interval When “Type to filter” is chosen, the database is retrieved with this frequency. If the user has 
filtered the Directory contents, then when this timer expires, the filter is lost and the entire 
database is displayed again.
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Attribute Mapping

All fields The Attribute Mapping panel is used to map the attributes that are in your directory to the 
corresponding fields in Bria. The panel shows the Bria fields that appear in the Contact Profile. 
Enter the attribute names that are in your directory; for example, if your directory stores mobile 
numbers as the “cell” attribute, enter cell in the Mobile number field. 
Be careful with this mapping because when users create a contact from a directory entry, Bria will 
allow/disallow certain functions (such as sending an IM) based on whether a given "contact 
method" is populated. Specifically:
• Softphone: Bria recognizes a value in this field as a softphone address and will map this field to 

the Softphone contact method for the contact. Bria considers a Softphone address as one that 
can be phoned and (if SIP is being used for IM/presence) as one that can be used for IM/
presence.

• Jabber: Bria recognizes a value in this field as a Jabber (XMPP) address and will map this field 
to the Jabber contact method for the contact. Bria considers a Jabber address as one that can be 
used for IM/presence (if XMPP is being used for IM/presence).

ADSI (Active Directory) Settings

Field Description
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Preferences – Calls

Table 11: Preferences – Calls

Field Description

Answer Calls These settings let you configure how you want auto answer to handle incoming calls, 
when Auto Answer is enabled. (To enable Auto Answer, see page 15)

DTMF You may need to change the DTMF configuration if you cannot interact with interactive 
voice response systems (auto attendants, voice-activated menus, and so on).
Contact your VoIP service provider or your system administrator for the correct setting.
In-band means that Bria will encode the DTMF signals in the audio stream as regular 
sound. Typically, DTMF is not sent in-band; in-band is only used in specific situations. 
One scenario in which it might be advisable to send in-band is if you own your gateways 
and:
• One or more of these gateways does not support RFC 2833 or does not handle it well, 

and
• Your gateway is using codes that reproduce DTMF tones well.

In this case, sending in-band will ensure that DTMF tones get through (because the 
DTMF tones will bypass the gateway) and that they reproduce accurately at the 
receiving end.

RTP This timer controls how calls are disconnected when Bria determines that there is a 
problem with the call and the other party has probably disappeared (assuming that you 
have not yourself detected the problem and hung up manually).
• Typically, the timer is enabled. It is recommended that you not disable it. You can 

change the length of the timer, but do not set it to less than 30 seconds.
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Preserve bandwidth When this feature is on, Bria stops sending audio when you are not talking.
When this feature is off, Bria always sends audio, which uses more bandwidth but may 
result in better call quality.
Typically off. However, if you are using a slow (dial-up or ISDN) connection, you may 
want to turn it on. 

Table 11: Preferences – Calls

Field Description
98



Bria 4 for Windows User Guide
Preferences – Files & Web Tabs

Table 12: Preferences – Files & Web Tabs

Field Description

Recording folder The folder where files for recording of phone calls will be saved.

File transfer folder The folder where received files will be saved. 

Web Page Tabs You can set up a web page as a new tab in the Resources panel; it will appear alongside   
Contacts, History and so on.
Enter the web address and a name (this name will be appear in the tab). Enter a checkbox 
to create the tab. 
At any time, you can clear the checkbox to remove the tab from the Resources panel.
You can also simply show or hide the tab from the View menu in the Bria menu.
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10 Administrator Tasks

10.1 Setting up Chat Rooms
If you support XMPP accounts, you can set up persistent chat rooms on your XMPP server. Users with accounts 
on that XMPP server can then join any chat room (View > Chat Rooms).

Chat rooms are set up to allow the same group of people to have a group IM session, usually on a regular basis. 
The chat room feature involves persistent groups, while the group chat feature creates ad-hoc groups.

Bria supports the following features:

• Open chat rooms: users can join without being already set up as a member of the group.
• Members-only chat rooms: users can join only if already set up as a member.
• Password-protected (confidential) chat rooms: users must enter the password to join.

On your XMPP server, create the chat room. Add members if desired and if supported by your XMPP server. 
Assign passwords if desired and if supported by your XMPP server.

10.2 Managing Licenses
When you obtain Bria, you purchase a license with a specified number of seats. Each time a user enters the 
license key, the license count is drawn down on the CounterPath license database. When the count is drawn 
down to 0, then the next time the key is entered, an error message appears for that user. 

You can either increase your license count or revoke unused seats. To revoke seats, go to 
www.counterpath.com, click the Store link, click the Your Account link, and log in.

Currently, a license count can be shared by users on the same computer if the users are using the Windows 
administrator or regular user accounts. However, a user who uses this computer with the Windows guest 
account and starts Bria will automatically draw down the license count (assuming that a license key has already 
been entered). 

Therefore, if you seem to have drawn down more license counts than expected, the problem may be that one or 
more guests have used seats. You can request that CounterPath revoke these licenses in order to reinstate the 
number of seats actually in use.

Setting up for the Licensing Server
Periodically, Bria connects to CounterPath’s license server in order to verify that a valid license is being used. 
Therefore, at all times, Bria will need to have an internet connection.

Bria connects to https://secure.counterpath.com via port 443; make sure your firewall allows this HTTPS traffic 
to this URL. In addition, if you have explicitly set a web proxy (Start > Control Panel > Internet Options > 
Connections) then Bria will use this proxy; make sure the proxy allows this traffic.
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Distributing License Keys to End Users
End users can import and export multiple license keys to Bria. You, as an administrator, can create a csv file 
with multiple license keys and send the file to end users to activate Bria. 

The file format is very simple: just separate keys with a comma, such as:

key1,key2,key3

Instructions for your Users
1. Obtain a license key file from your administrator.

2. Start Bria, and choose Help > Enter License Key. The License Key Management window appears.

3. Click Import Keys.

4. Choose the license key file provided by your administrator. The keys appear in the window.

5. Click Done.
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A Application Hot Keys
Category Function Keyboard Shortcut

Making or answering a 
call

Answer an incoming call Ctrl + N

Decline an incoming call Ctrl + D

Redial the last dialed number Ctrl + R
or Ctrl + R then Enter

End the call
End the conference call (hang up on all 
participants)

Ctrl + E

During a call Mute your voice during a call Ctrl + M

Hold or resume the call when the focus is on 
this call panel

Ctrl + H

Transfer an established call when the focus is 
on this call panel 

Ctrl + T

Turn volume up when the focus is on this call 
panel 

Up key

Turn volume down when the focus is on this 
call panel 

Down key

Display in full screen when the focus is on 
the video window

F11

During a screen share 
session

Bring the screen share window to the front 
and in focus

Shift + Ctrl + Alt + S

Opening a window Open the Messages window Shift + Ctrl + M

Open the Preferences window F8

Open Troubleshooting Diagnostics Ctrl + F9

Open Help in a browser F1

Exiting Quit Bria Ctrl + Q
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B Contact List Headings
Following is a list of all the headings that are used in the Bria contact list. This list can be useful when 
formatting a contact list in order to import it into Bria. For details, see “Populating by Importing Contacts” on 
page 46.
The same headings are used for both Bria for Mac and Bria for Windows.

Heading Description

business_number

business_numbern, where n is 2 to 6

categories Maps to Bria groups

default_address Maps to the Presence field

default_address_comm Always specifies IM, if default_address is specified. This heading 
does not map to a Contact Profile field 

default_address_type Specifies SIP or XMPP

display-name

email_address

email_addressn, where n is 2 to 6

fax_number

fax_numbern, where n is 2 to 6

given_name

home_number

home_numbern, where n is 2 to 6

mobile_number

mobile_numbern, where n is 2 to 6

other_address

other_addressn, where n is 2 to 6

postal_address

presence_subscription TRUE or FALSE

sip_address Maps to the Softphone field.

sip_addressn, where n is 2 to 6

surname

web_page

web_pagen, where n is 2 to 6

xmpp_address Maps to the Instant Message field. This field must always specify an 
XMPP address

xmpp_addressn, where n is 2 to 6
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C Other Ways to Run Bria 
You can attach a hyperlink to a phone number or softphone address that, when clicked, starts Bria and dials the 
number. Attach a hyperlink with this format:

<a href="sip:address_or_number">dial address_or_number</a>

For example:

<a href="sip:kperera@domainA.com">dial kperera@domainA.com</a>

Bria supports three protocols: sip, tel, and callto. For Bria to start dialing when a user clicks such links, the user 
must configure Bria as their default phone via Bria’s Preferences, and then associate the protocols to Bria.

Click

Select the 
protocols and 
click Save.
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D Glossary
Broadband Broad or wide bandwidth. In data transmission, the wider the band, the more data it is 

possible to transmit in a given time span. A cable, DSL and ADSL connection to the 
network provide broadband for data transmission. A dialup or ISDN connection 
typically provide a narrow bandwidth for data transmission.

Codec Codecs are programs in Bria involved in transmitting audio; each codec has different 
characteristics and therefore each works better in some situations than in others

Dial plan The rules that Bria follows in order to interpret the softphone address or phone 
number that the user has entered and to modify the number or address, as required, to 
ensure that the call will be placed successfully. 

DTMF Dual-tone multi frequency. DTMF is the system that is used in interactive voice-
response menu systems such as the menu system for accessing voicemail messages. 
The DTMF system allows the user to interact with the menu by pressing keys on a 
dialpad or keyboard.

Firewall A technology that prevents unauthorized people connecting to your computer and to 
the applications running on the computer. 

IM Instant Messaging. A technology that lets users send text message and files for near 
instantaneous delivery and display on each others’ computers.

MWI Message Waiting Indicator. An indicator that there is a voicemail message for the 
owner of an account.

Narrowband In data transmission, the wider the band, the more data it is possible to transmit in a 
given time span. A cable, DSL and ADSL connection to the network provide 
broadband for data transmission. A dialup or ISDN connection typically provide a 
narrow bandwidth for data transmission.

Presence An instant messaging feature that allows users to share information about their online 
status.

PSTN Public Switch Telephone Network. The traditional land-line phone network.
SIP account An account that provides the user the ability to make VoIP phone calls. The account 

encapsulates the rules and functions the user can access.
softphone address The address used to connect to a SIP endpoint. In other words, the “phone number” 

used in a VoIP phone call. For example, sip:joseph@domainA.com.
USB device Universal Serial Bus device. A device that follows a specific communications 

standard. A headset may be a “USB type” of headset. 
vCard An electronic business card that is often attached to an e-mail. It often appears as a 

“signature” block that identifies the person, their title, and their business.
VoIP Voice over Internet Protocol. A variation of IP used for sending voice data over the 

internet, in other words, used for making phone calls over the internet.
VoIP service provider A business that provides a VoIP service, allowing a user to connect to the internet in 

order to make VoIP phone calls using Bria. The VoIP service provider sets up a SIP 
account for the user. 

XMPP account An account that provides the user with the ability to send IMs and view other people’s 
presence. 
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